A computer components & hardware forum. HardwareBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » HardwareBanter forum » General Hardware & Peripherals » General
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Compaq Armada 110 Laptop - Repair Help



 
 
Thread Tools Display Modes
  #1  
Old July 7th 07, 04:58 AM posted to nz.comp,alt.comp,comp.sys.laptops,alt.comp.hardware
[email protected]
external usenet poster
 
Posts: 40
Default Compaq Armada 110 Laptop - Repair Help

Hi All,

I have a laptop here that the user reports is dead. No lights at power
on or any signs of life.

The power adapter is outputting the correct volatge - check it with a
multi meter.

So I found the service manual and took the laptop apart, and when I
put the power plug in the led on the motherboard came to life, so I
put it back together and it booted into windows XP - yay.

Then to be sure I tried to boot it again and it wouldnt boot at all,
no power led's, but now I do hear the HDD spool up and the light on
the side of the CD tray comes on.

Something is clearly wrong, but I have not really tried to repair too
many laptops before. I was doing some reading on repairing laptops,
and I think I should start with finding the volatge regulator and
seeing if it is putting out the right voltages?

Love to hear any other thoughts on how to try to fix this.

-Al

  #2  
Old July 7th 07, 05:24 AM posted to nz.comp,alt.comp,comp.sys.laptops,alt.comp.hardware
Edward C.
external usenet poster
 
Posts: 3
Default Compaq Armada 110 Laptop - Repair Help

The power supply needs to be changed. Unless you want to repair it
yourself. Whatever is cheaper for you.

-Edward


On Jul 6, 8:58 pm, wrote:
Hi All,

I have a laptop here that the user reports is dead. No lights at power
on or any signs of life.

The power adapter is outputting the correct volatge - check it with a
multi meter.

So I found the service manual and took the laptop apart, and when I
put the power plug in the led on the motherboard came to life, so I
put it back together and it booted into windows XP - yay.

Then to be sure I tried to boot it again and it wouldnt boot at all,
no power led's, but now I do hear the HDD spool up and the light on
the side of the CD tray comes on.

Something is clearly wrong, but I have not really tried to repair too
many laptops before. I was doing some reading on repairing laptops,
and I think I should start with finding the volatge regulator and
seeing if it is putting out the right voltages?

Love to hear any other thoughts on how to try to fix this.

-Al



  #3  
Old July 7th 07, 06:03 AM posted to nz.comp,alt.comp,comp.sys.laptops,alt.comp.hardware
[email protected]
external usenet poster
 
Posts: 40
Default Compaq Armada 110 Laptop - Repair Help

On Jul 7, 4:24 pm, "Edward C." wrote:
The power supply needs to be changed. Unless you want to repair it
yourself. Whatever is cheaper for you.

-Edward

On Jul 6, 8:58 pm, wrote:



Hi All,


I have a laptop here that the user reports is dead. No lights at power
on or any signs of life.


The power adapter is outputting the correct volatge - check it with a
multi meter.


So I found the service manual and took the laptop apart, and when I
put the power plug in the led on the motherboard came to life, so I
put it back together and it booted into windows XP - yay.


Then to be sure I tried to boot it again and it wouldnt boot at all,
no power led's, but now I do hear the HDD spool up and the light on
the side of the CD tray comes on.


Something is clearly wrong, but I have not really tried to repair too
many laptops before. I was doing some reading on repairing laptops,
and I think I should start with finding the volatge regulator and
seeing if it is putting out the right voltages?


Love to hear any other thoughts on how to try to fix this.


-Al- Hide quoted text -


- Show quoted text -


Hmm, you mean the power side of the circuit inside the laptop? Its
part of the main system board, so no easily replaceable.

The PSU caps incidentially look ok.

  #5  
Old July 8th 07, 04:32 PM posted to nz.comp,alt.comp,comp.sys.laptops,alt.comp.hardware
kony
external usenet poster
 
Posts: 7,416
Default Compaq Armada 110 Laptop - Repair Help

On Sat, 07 Jul 2007 03:58:23 -0000,
wrote:

Hi All,

I have a laptop here that the user reports is dead. No lights at power
on or any signs of life.

The power adapter is outputting the correct volatge - check it with a
multi meter.

So I found the service manual and took the laptop apart, and when I
put the power plug in the led on the motherboard came to life, so I
put it back together and it booted into windows XP - yay.

Then to be sure I tried to boot it again and it wouldnt boot at all,
no power led's, but now I do hear the HDD spool up and the light on
the side of the CD tray comes on.

Something is clearly wrong, but I have not really tried to repair too
many laptops before. I was doing some reading on repairing laptops,
and I think I should start with finding the volatge regulator and
seeing if it is putting out the right voltages?

Love to hear any other thoughts on how to try to fix this.

-Al


Yes, failing any more obvious evidence of the source of the
problem, you might start by checking the AC-DC brick's
voltage output while it's powering the laptop, then take the
(meter) probes and probe around following the brick power
circuit through the mainboard power regulation stages.

Since it did boot once, then failed again after being put
back together, also check for intermittent electrical
connections and circuit board cracks & broken solder joints.
It might help to have a strong light during an examination.
 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Compaq Armada 4210T Laptop (more details) Brad General 2 February 16th 07 09:35 PM
Dead Compaq Armada 4210T Laptop Brad General 1 February 14th 07 11:11 PM
Dead Compaq Armada 4210T Laptop Brad General 1 February 13th 07 08:28 PM
directions to reformat my Compaq Armada 7800 laptop DunbarPPL Compaq Computers 2 March 30th 05 02:10 PM
Laptop Parts for Compaq Armada 1700 / 1750 Wesley Compaq Computers 0 July 16th 03 07:03 PM


All times are GMT +1. The time now is 07:08 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2004-2022 HardwareBanter.
The comments are property of their posters.