A computer components & hardware forum. HardwareBanter

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Go Back   Home » HardwareBanter forum » Video Cards » Ati Videocards
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

Radeon 9600 pro - totally unstable



 
 
Thread Tools Display Modes
  #1  
Old December 3rd 03, 03:38 PM
Dominik Jain
external usenet poster
 
Posts: n/a
Default Radeon 9600 pro - totally unstable

Hello everyone,

I have recently acquired a Sapphire Atlantis Radeon 9600pro (using driver
ver. 7.94 on Win2k).
Ever since, quite regularly, applications just freeze and the screen is
garbled. Then, the screen turns black and is shortly thereafter restored,
with graphics performace dropping drastically. I've also had several blue
screens and unrecoverable freezes that left me no choice but to reboot.
None of this ever happened before the graphics card was upgraded; my system
was totally stable.

Any ideas on how this can be fixed? It seems that the Radeon drivers are
hardly acceptable. Stability being my key concern, it is needless to say
that I am very disappointed with my first ATI card.

Any help would be greatly appreciated.

cheers!

--
Dominik Jain
http://flash.to/oblivion

  #2  
Old December 3rd 03, 10:27 PM
Ben Pope
external usenet poster
 
Posts: n/a
Default

Dominik Jain wrote:
Hello everyone,

I have recently acquired a Sapphire Atlantis Radeon 9600pro (using driver
ver. 7.94 on Win2k).
Ever since, quite regularly, applications just freeze and the screen is
garbled. Then, the screen turns black and is shortly thereafter restored,
with graphics performace dropping drastically. I've also had several blue
screens and unrecoverable freezes that left me no choice but to reboot.
None of this ever happened before the graphics card was upgraded; my
system was totally stable.

Any ideas on how this can be fixed? It seems that the Radeon drivers are
hardly acceptable. Stability being my key concern, it is needless to say
that I am very disappointed with my first ATI card.


Could be the extra draw on your PSU causing problems. What make and wattage
is it? More to the point, whats the current avaliable on the 12V rail?

What CPU/RAM/Motherboard/Chipset?

Did you use det destroyer to get rid of the old geforce drivers (if you came
from nVidia)?

Ben
--
A7N8X FAQ: www.ben.pope.name/a7n8x_faq.html
Questions by email will likely be ignored, please use the newsgroups.
I'm not just a number. To many, I'm known as a String...


  #3  
Old December 3rd 03, 11:15 PM
Kent_Diego
external usenet poster
 
Posts: n/a
Default

Check the forums at:
http://rage3d.com

Adjusting BIOS options sometimes helps. Be sure to have latest AGP chip set
driver for your motherboard.

-Kent


  #4  
Old December 3rd 03, 11:47 PM
Paul Lower
external usenet poster
 
Posts: n/a
Default

Hi
WTF are drivers 7.94? You should be using Catalyst drivers 3.8 or 3.9!
Paul
"Dominik Jain" wrote in message
...
Hello everyone,

I have recently acquired a Sapphire Atlantis Radeon 9600pro (using driver
ver. 7.94 on Win2k).
Ever since, quite regularly, applications just freeze and the screen is
garbled. Then, the screen turns black and is shortly thereafter restored,
with graphics performace dropping drastically. I've also had several blue
screens and unrecoverable freezes that left me no choice but to reboot.
None of this ever happened before the graphics card was upgraded; my

system
was totally stable.

Any ideas on how this can be fixed? It seems that the Radeon drivers are
hardly acceptable. Stability being my key concern, it is needless to say
that I am very disappointed with my first ATI card.

Any help would be greatly appreciated.

cheers!

--
Dominik Jain
http://flash.to/oblivion



  #5  
Old December 4th 03, 12:11 AM
Ben Pope
external usenet poster
 
Posts: n/a
Default

Paul Lower wrote:
Hi
WTF are drivers 7.94?


Cat 3.8

You should be using Catalyst drivers 3.8 or 3.9!


:-)

Ben
--
A7N8X FAQ: www.ben.pope.name/a7n8x_faq.html
Questions by email will likely be ignored, please use the newsgroups.
I'm not just a number. To many, I'm known as a String...


  #6  
Old December 4th 03, 12:19 AM
Dominik Jain
external usenet poster
 
Posts: n/a
Default

Ben Pope wrote:
I have recently acquired a Sapphire Atlantis Radeon 9600pro (using
driver ver. 7.94 on Win2k).
Ever since, quite regularly, applications just freeze and the screen
is garbled. Then, the screen turns black and is shortly thereafter
restored, with graphics performace dropping drastically. I've also
had several blue screens and unrecoverable freezes that left me no
choice but to reboot. None of this ever happened before the graphics
card was upgraded; my system was totally stable.

Any ideas on how this can be fixed? It seems that the Radeon drivers
are hardly acceptable. Stability being my key concern, it is
needless to say that I am very disappointed with my first ATI card.


Could be the extra draw on your PSU causing problems. What make and
wattage is it? More to the point, whats the current avaliable on the
12V rail?

What CPU/RAM/Motherboard/Chipset?


If those are common symptoms related to power, it most certainly is the
power supply... I only have 235W, which could be too little for the
following:
- duron 1200
- asus a7v (kt133)
- 2 hdd's, 7200rpm
- dvd-rw
- 512mb pc133
- hauppauge tv card
- network card
- soundcard
- and of course, the radeon

Did you use det destroyer to get rid of the old geforce drivers (if
you came from nVidia)?


I came from 3dfx (voodoo3).

How much more power does the radeon draw compared to that voodoo3?
Well, I guess I won't get around spending some more money on a new power
supply...

cheers!

--
Dominik Jain
http://flash.to/oblivion

  #7  
Old December 4th 03, 12:55 AM
Ben Pope
external usenet poster
 
Posts: n/a
Default

Dominik Jain wrote:
If those are common symptoms related to power, it most certainly is the
power supply... I only have 235W, which could be too little for the
following:


Arghhh!! Buy a new PSU now! I'll guarantee thats your problem :-)

I suggest either a good 350W or a cheapo (that doesn't mean crap :-) 450W
(or probably somewhere in between). If you're planning on going Athlon XP
and new mobo at some point, add a good 50W to 100W to that for a good safety
margin.

- duron 1200
- asus a7v (kt133)
- 2 hdd's, 7200rpm
- dvd-rw
- 512mb pc133
- hauppauge tv card
- network card
- soundcard
- and of course, the radeon

Did you use det destroyer to get rid of the old geforce drivers (if
you came from nVidia)?


I came from 3dfx (voodoo3).


Good man, me too :-)

How much more power does the radeon draw compared to that voodoo3?
Well, I guess I won't get around spending some more money on a new power
supply...


More... enough to cause you problems. The 9800 (R350) is ~70W, IIRC. The
9600 (RV350) should be a little down on that as it's 0.13 not 0.15, but
wouldn't expect it to be less than 50W. No idea what the Voodoo would have
been.

Ben
--
A7N8X FAQ: www.ben.pope.name/a7n8x_faq.html
Questions by email will likely be ignored, please use the newsgroups.
I'm not just a number. To many, I'm known as a String...


  #8  
Old December 5th 03, 07:59 PM
Thomas
external usenet poster
 
Posts: n/a
Default

Ben Pope wrote:
- duron 1200
- asus a7v (kt133)
- 2 hdd's, 7200rpm
- dvd-rw
- 512mb pc133
- hauppauge tv card
- network card
- soundcard
- and of course, the radeon


More... enough to cause you problems. The 9800 (R350) is ~70W, IIRC.
The 9600 (RV350) should be a little down on that as it's 0.13 not
0.15, but wouldn't expect it to be less than 50W. No idea what the
Voodoo would have been.


Well, i'd upgrade the PSU of course (indeed about 350 of a good brand, or
400 for a B-brand. DOnt go for a C-brand, if you get my drift ;-) ), but
also check if you have the lastest mainboard drivers installed
(http://www.viaarena.com/?PageID=2)
And if the BIOS for your mainboard is a bit prehistoric, that might be a
problem too.

Thomas.


 




Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon 9600 or 9600 Pro for MCE 2005? Tiny Tim Homebuilt PC's 17 December 10th 04 01:16 AM
pc problems after g card upgrade + sp2 ben reed Homebuilt PC's 9 November 30th 04 01:04 AM
Direct 3D Problem: ATI Radeon 9600 / Aopen ax4spe motherboard M.D. Ati Videocards 3 October 20th 03 03:19 PM
Which Radeon 9600 Pro Bolton Gate Ati Videocards 8 September 27th 03 11:40 PM
Radeon 9600 or 9600 Pro ? Marshalls Ati Videocards 0 June 22nd 03 11:03 PM


All times are GMT +1. The time now is 11:02 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright 2004-2022 HardwareBanter.
The comments are property of their posters.